Sayfalar

Saturday, October 9, 2010

GNS3 Topology: ASA Clientless Remote Access SSL (Web) VPN Configuration

Clientless SSL VPN feature is great. I really enjoyed when I was learning it. When I first connected to the PC sitting on the inside network or telnet into router through ASA without anything but a browser, I was amazed. It is really cool. You should try this one :)



PART 1


PART 2


Initial Configurations

ASA1
hostname ASA-Izmir
int e0/0
   ip add 192.168.2.254 255.255.255.0
   nameif inside
   no shut
int e0/1
   ip add 157.55.1.254 255.255.255.0
   nameif outside
   no shut
route outside 0 0 157.55.1.1 1
route inside 192.168.3.0 255.255.255.0 192.168.2.100
http server enable
http 0 0 inside
telnet 0 0 inside
telnet timeout 30
asdm image flash:/asdm.bin
nat-control
global (outside) 1 interface
nat (inside) 1 192.168.2.0 255.255.255.0
access-list acl_outside_in permit icmp any interface outside echo-reply
access-group acl_outside_in in interface outside
username levent password xxxxxxxx privilege 15

R2
interface FastEthernet0/0
 ip address 192.168.2.100 255.255.255.0
 no shut
!
interface FastEthernet1/0
 ip address 192.168.3.254 255.255.255.0
 no shut
!
ip route 0.0.0.0 0.0.0.0 192.168.2.254
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end

R1
enable secret xxxxxxxxx
interface FastEthernet0/0
 ip address 157.55.1.1 255.255.255.0
 no shut
!
interface FastEthernet1/0
 ip address 192.168.10.254 255.255.255.0
 no shut
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end

No comments:

Post a Comment